steer wheel / Dash

Discussion in 'Gen 2 Prius Technical Discussion' started by Tombukt2, Jun 6, 2022.

  1. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    1,510
    236
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    So the other day I took the steering wheel out of my Nice condition 05 and put it in my 09 keeping the buttons the clock spring and everything in the 09 original so the buttons on the steering wheel are from the 09 on the 04 wheel after I did this the horn honked one time never again all the buttons on the steering wheel work perfectly volume mode everything thinking it's the clock spring then today I cleared out an 08 car and beautiful shape got the complete interior including a perfect dash that works now I have a display and everything and I have the airbag light on and I have a solar sensor issue I noticed when I was changing the dash some very minute things on the back of the dash look different not electrical connectors I need to look at the date on the back of the dash pad I didn't make a note of it mine is in 808 so I'm going to take the solar sensor out of my 09 - and plug it in to what's in my 09 now that came out of an 08 and hopefully that will clear the solar sensor problem up and going to clock the airbag light to being the clock spring which also deals with my horn and I didn't have an airbag light on in my original dash and everything because that's what the problem with the dash is my thinking sound?
     
  2. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    17,268
    11,737
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    I could maybe tell if it were punctuated
     
    SFO and PriusCamper like this.
  3. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    1,510
    236
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    The solar sensor change made no difference so I'm guessing maybe the clock spring also has something to do with the solar sensor wiring because that would make sense I'm assuming my horn doesn't work because of the clock spring which would also do my SRS thingy like and maybe give me the solar sensor code because the wiring is good it goes off to the computers comes down and goes into the two big white plugs which all are fine weird.
     
  4. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    1,510
    236
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    All comes back to the steering wheel change when I had no dash display makes sense to me putting in the dash from the 807 car shouldn't have made any code changes to airbag in the solar sensor basically are the same parts it looks like plugs and everything so I'm guessing I would have been having this SRS code I just couldn't see it because of no display Tah dah
     
  5. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    17,268
    11,737
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    Solar sensor wiring doesn't go through the spiral cable. You can see it in the wiring diagram.
     
  6. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    1,510
    236
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    I don't have diagram but I ripped the dash back off and everything is plugged up so I put the solar sensor that was working 20 minutes ago there and that's that I'm going to guess my SRS problems from my steering wheel change in my clock spring is all of a sudden just bad
     
  7. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    1,510
    236
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    Well you're all going to love this yesterday I stripped the middle eight blue Prius not a base but not a tour not hid car in absolute mint condition I talked to the owner of the car no one's ever sat in it except for him he bought the car when it was brand new he knew it was the right thing to do the car has never seen a dealership or a service Bay it's whole life it looks brand new the guy claims the engine failed by looking at the engine the oil and the rest of the car I say there's no way it has a brand new battery just like mine in the trunk I had to dig to get to it it's all put back every nut and bolt I stripped the interior out of the car including the dash which the man said his work all the cars life it's never glitched or turned off not for a second I put these parts in my car yesterday and immediately had a dash all day long drove the car turned it off at least a hundred times - lit back up every time I turn the car on got in the car this morning first pushing the button no dash immediately turn the car off re push the button with the brake dash is on there is something further up the line causing this problem it's not the dash I don't think I find this very interesting.
     
  8. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    1,510
    236
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    It has a brand new hybrid battery in it it's probably not 7 months old I can go back and get the rest of the stuff out of the car for probably $300 probably going to do it today or tomorrow
     
Loading...