Surging at stoplights.

Discussion in 'Gen 2 Prius Main Forum' started by Prius92, May 23, 2020.

  1. Prius92

    Prius92 Junior Member

    Joined:
    Sep 14, 2019
    57
    17
    0
    Location:
    Iowa
    Vehicle:
    2008 Prius
    Model:
    II
    My 2008 surges at stoplights. Sometimes it feels like the engine doesn't totally shut down and kicks around a few more times. You can literally feel the car "buck" forward a little bit.

    No codes, no misfires reported, battery is ok. Plugs and air filter changed recently as well as cleaning of the throttle body. No difference...

    I did notice the oil smelt rather gassy despite being changed around 4,000 miles ago.
     
    Data Daedalus likes this.
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    87,554
    38,973
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    how many miles on her?
     
    Data Daedalus likes this.
  3. Prius92

    Prius92 Junior Member

    Joined:
    Sep 14, 2019
    57
    17
    0
    Location:
    Iowa
    Vehicle:
    2008 Prius
    Model:
    II
    131k.
     
    Data Daedalus likes this.
  4. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    87,554
    38,973
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    try disconnecting the 12v neg for a minute to reset the computers.

    sounds like it's hunting for the correct timing position to shut down
     
  5. Data Daedalus

    Data Daedalus Senior Member

    Joined:
    Jul 6, 2013
    951
    1,064
    0
    Location:
    Wembley, London
    Vehicle:
    2008 Prius
    Model:
    II
    My 2008 UK Tspirit will occasionally do something similar. It’s like it’s time for the I.C.E. to do it’s MECO thing, but it burbles and rumbles ever so slightly for a second or two before achieving MECO.

    This is usually observed when the I.C.E. is still in the warming stage and hasn’t quite reached the “S4” phase yet.

    I’ve also observed it more in colder weather. At 26c for example, it virtually doesn’t happen.

    Once the I.C.E. has reached S4 warming stage, MECO takes place seamlessly without any hindrance or hesitation.

    I’m presently at 123k by the way.

    * MECO = Main Engine Cut Off.
    Why? Because I call it “The Spaceship” .


    iPhone 6s +
     
    bisco likes this.
  6. Mendel Leisk

    Mendel Leisk Senior Member

    Joined:
    Oct 17, 2010
    39,359
    27,994
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    Deleted, guilty of topic drift once again.
     
  7. Prius92

    Prius92 Junior Member

    Joined:
    Sep 14, 2019
    57
    17
    0
    Location:
    Iowa
    Vehicle:
    2008 Prius
    Model:
    II
    Checked the car with my OBD2 scanner. No misfire counts.
     
  8. AzWxGuy

    AzWxGuy Weather Guy

    Joined:
    May 22, 2011
    707
    318
    0
    Location:
    Tucson, AZ
    Vehicle:
    2011 Prius
    Model:
    Three
    Two things I thought of in addition to the above. When you say surging, how long time-wise does it do this? Always at idle, or only when shutting down? I remember mine would go up and down in rpm once maybe twice and stop. Probably normal if that is the extent of it. If it's continuous or nearly continuous it might be storing up an oxygen sensor fault. Gassy oil though, dilution maybe. Bad fuel injector(s)? What's your mpg?
     
  9. Prius92

    Prius92 Junior Member

    Joined:
    Sep 14, 2019
    57
    17
    0
    Location:
    Iowa
    Vehicle:
    2008 Prius
    Model:
    II
    Well I tore down into the engine and found one of the spark plugs was a bit loose, other than that everything else was fine.
    Checked the pcv valve and hoses and they were fine.

    I noticed the surging seems to happen when the engine is cool more so than when warmed up after 20ish minutes of driving.

    The RPM does not change, but I will be sitting at a stoplight and notice the car seems to "buck forward" a little bit.

    The best way I can describe it, is the engine is momentarily "kicking on" for a split second or two for about 3-4 times, then shutting off completely as it should.

    The MPG is fine, and I will say the car has done it since purchased, and new plugs, new air filter, and about 3 tank fulls of gas with techron injector cleaner as well as a new 12v battery made no difference.

    No check engine lights, no codes stored, no misfires per the scanner I have.
     
    #9 Prius92, May 27, 2020
    Last edited: May 27, 2020
  10. Prius92

    Prius92 Junior Member

    Joined:
    Sep 14, 2019
    57
    17
    0
    Location:
    Iowa
    Vehicle:
    2008 Prius
    Model:
    II
    I do recall reading somewhere than the engine has to be stopped in a correct position, and if the engine does not shut off in this position, the computer will rotate the engine a couple times until it finds the correct spot.

    Is this true?
     
    Data Daedalus likes this.
  11. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    87,554
    38,973
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    yes. perhaps a sesor issue, but you'd think it would throw a code
     
    Data Daedalus likes this.
  12. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    87,554
    38,973
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    tbh, if you're new to hybrids, it might be normal
     
    Data Daedalus likes this.
Loading...