Suspension making squeaking sounds, what could it be? Video

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by bronx99, Mar 17, 2019.

  1. bronx99

    bronx99 New Member

    Joined:
    Mar 17, 2019
    4
    0
    0
    Location:
    Irvine, CA
    Vehicle:
    2010 Prius
    Model:
    II
    I plan on taking it to a shop, but just wanted some of your takes so I know what i'm dealing with. I'm guessing it's either the shock/spring, ball joints or bushings. Thanks!


     
  2. bronx99

    bronx99 New Member

    Joined:
    Mar 17, 2019
    4
    0
    0
    Location:
    Irvine, CA
    Vehicle:
    2010 Prius
    Model:
    II
    the weird thing about it as well - is that the sound only happens when i'm coming home from a drive. In the morning when i get in my car, the sound is not there.
     
  3. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    95,270
    43,196
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    how many miles on her?
     
  4. bronx99

    bronx99 New Member

    Joined:
    Mar 17, 2019
    4
    0
    0
    Location:
    Irvine, CA
    Vehicle:
    2010 Prius
    Model:
    II
  5. Greenteapri

    Greenteapri Active Member

    Joined:
    Nov 19, 2018
    328
    383
    0
    Location:
    Cypress
    Vehicle:
    2013 Prius
    Model:
    Three
    Mine does the same thing. It's the exhaust spring bolts. It only happens after she's warm. Wd-40 should do the trick but I'm to lazy. :LOL::LOL::LOL:

    Plus I like rocking the car, when she's making noise, while looking at my girlfriend with devilish eyes:love::love::love:
     
    The Critic likes this.
  6. bronx99

    bronx99 New Member

    Joined:
    Mar 17, 2019
    4
    0
    0
    Location:
    Irvine, CA
    Vehicle:
    2010 Prius
    Model:
    II
    Where can i find the exhaust spring bolts? any pics?
     
  7. Pluggo

    Pluggo Senior Member

    Joined:
    May 23, 2016
    604
    527
    0
    Location:
    Folsom, Pennsylvania
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Advanced
    WD-40 on exhaust parts? No, I think it would all burn off during your first drive.
     
  8. Greenteapri

    Greenteapri Active Member

    Joined:
    Nov 19, 2018
    328
    383
    0
    Location:
    Cypress
    Vehicle:
    2013 Prius
    Model:
    Three
    full-10688-328-borlaexhaustinstall001.jpg
    They look like this.

    Follow your exhaust piping and spray away.

    Operating temp for wd-40 is up to 300°f.
     
    #8 Greenteapri, Mar 21, 2019
    Last edited: Mar 21, 2019
  9. Colm01

    Colm01 Member

    Joined:
    Aug 12, 2014
    83
    73
    0
    Location:
    Wilmington, DE
    Vehicle:
    2010 Prius
    Model:
    V
    My Prius is making the same sound @ 120K. It's the front sway bar links. Only does it when hot, on the way home from work. I can see the rubber boots cracked and torn allowing the elements into the ball socket. I'm going to change them this weekend. I'll update.
     
    Raytheeagle likes this.
  10. padroo

    padroo Senior Member

    Joined:
    Jan 11, 2008
    2,763
    2,243
    13
    Location:
    Chesterton, Indiana Another third world country.
    Vehicle:
    2016 Prius
    Model:
    Four
    When I changed the front struts on my 2008 Prius I installed new sway bar links that I got from Advance Auto. There was a selection from different companies and the one I used had bad reviews because it was noisy and it squeaked right out of the box. I returned it and used another brand but don't remember the brand name, just read the reviews is all I am suggesting.
     
    Colm01 likes this.
  11. Colm01

    Colm01 Member

    Joined:
    Aug 12, 2014
    83
    73
    0
    Location:
    Wilmington, DE
    Vehicle:
    2010 Prius
    Model:
    V
    20190322_154843.jpg 20190322_160241.jpg Replaced the sway bar end links and the noise is gone! Two trips to and from work with no squeaks!. Here are the photos of the links.
     
  12. gliderman

    gliderman Active Member

    Joined:
    Aug 2, 2011
    750
    217
    0
    Location:
    Texas
    Vehicle:
    2010 Prius
    Model:
    IV
    Front or rear?
     
    Colm01 likes this.
  13. Colm01

    Colm01 Member

    Joined:
    Aug 12, 2014
    83
    73
    0
    Location:
    Wilmington, DE
    Vehicle:
    2010 Prius
    Model:
    V
    These were the front sway bar links.
     
    gliderman likes this.
  14. padroo

    padroo Senior Member

    Joined:
    Jan 11, 2008
    2,763
    2,243
    13
    Location:
    Chesterton, Indiana Another third world country.
    Vehicle:
    2016 Prius
    Model:
    Four
    Glad it worked out for you. What brand are the new ones?

    The rod part on my 2008 was round, I see they made some changes on Gen 3.
     
    Colm01 likes this.
  15. Colm01

    Colm01 Member

    Joined:
    Aug 12, 2014
    83
    73
    0
    Location:
    Wilmington, DE
    Vehicle:
    2010 Prius
    Model:
    V
    The new ones were Toyota. The aftermarket ones were round and made of steel so I steered away from them. I went with the OE aluminum ones.
     
  16. padroo

    padroo Senior Member

    Joined:
    Jan 11, 2008
    2,763
    2,243
    13
    Location:
    Chesterton, Indiana Another third world country.
    Vehicle:
    2016 Prius
    Model:
    Four
    Generally speaking you can't go wrong with OE equipment especially if the aftermarket maker has no recognizable name.
    Most of the time it comes down to price and availability.
    I have seen local parts stores supplying parts to dealers.
     
    Colm01 likes this.
Loading...