The external system is not connected

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by nbojaxhiu, Dec 8, 2016.

  1. nbojaxhiu

    nbojaxhiu New Member

    Joined:
    Nov 25, 2016
    24
    2
    0
    Location:
    kosovo
    Vehicle:
    2004 Prius
    Model:
    Persona
    Hi There,
    I have a 2004 Prius gen 2. Everything runs well thnx God! I have a problem with my MFD as mo0st of times it gives me message " The external system is not connected" and therefore I cant use the features of the MFD.

    I checked (diagnosed) the 12 V Auxiliary battery and it shows 14.1V which seems to be healthy.

    Any of you have any idea why cant connect the external system??
    Sometimes it works well and I can use the features and even make phone calla and use Navigation system.

    Thanks in advance!
     
  2. andrewclaus

    andrewclaus Active Member

    Joined:
    Sep 15, 2009
    993
    318
    0
    Location:
    Golden, CO
    Vehicle:
    2007 Prius
    Sorry I can't help with your communication error, but I will suggest you check the 12V battery in two other modes; 1) system off, 2) IG ON. If everything else is working, it's not likely to be a 12V error, but it's good to keep an eye on the battery. Your 14.1V reading is in "Ready" and it's charging from the hybrid system, which appears to be working.
     
    #2 andrewclaus, Dec 8, 2016
    Last edited: Dec 8, 2016
    nbojaxhiu likes this.
  3. nbojaxhiu

    nbojaxhiu New Member

    Joined:
    Nov 25, 2016
    24
    2
    0
    Location:
    kosovo
    Vehicle:
    2004 Prius
    Model:
    Persona
    Thnx for the reply, i will follow up your advice and come back to you.

    Posted via the PriusChat mobile app.
     
  4. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    5,301
    2,858
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    Push the driver's seat all the way back and then check that the 2 (or 3) plugs on the front of the black box on the floor under the driver's seat have not been accidentally dislodged. It might pay to unplug and then plug each one back in to confirm that they are all connected properly.
     
    #4 dolj, Dec 9, 2016
    Last edited: Dec 13, 2016
    nbojaxhiu likes this.
  5. nbojaxhiu

    nbojaxhiu New Member

    Joined:
    Nov 25, 2016
    24
    2
    0
    Location:
    kosovo
    Vehicle:
    2004 Prius
    Model:
    Persona
    i pushed the drivers seat and unplugged all plugs and plugged them back but situation remains the same. anyway thanks for the advise

    Posted via the PriusChat mobile app.
     
  6. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    5,301
    2,858
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    Incidentally, was your Prius originally supplied new in your country or imported?

    If imported, from which country was it imported?
     
  7. nbojaxhiu

    nbojaxhiu New Member

    Joined:
    Nov 25, 2016
    24
    2
    0
    Location:
    kosovo
    Vehicle:
    2004 Prius
    Model:
    Persona
  8. nbojaxhiu

    nbojaxhiu New Member

    Joined:
    Nov 25, 2016
    24
    2
    0
    Location:
    kosovo
    Vehicle:
    2004 Prius
    Model:
    Persona
    1481303101528.jpg

    can you confirm please if this battery is the proper one for prius 2004. thnx foto attached

    Posted via the PriusChat mobile app.
     
  9. nbojaxhiu

    nbojaxhiu New Member

    Joined:
    Nov 25, 2016
    24
    2
    0
    Location:
    kosovo
    Vehicle:
    2004 Prius
    Model:
    Persona
    Today it happened as usuall MFD did work but after 10 km drive everything came on working perfect with all features and didnt stop until i reached the destination. Again when started the trip didnt work MFD but after 10 km everything started working. can this be the battery issue or what could that be??? thnx

    Posted via the PriusChat mobile app.
     
  10. andrewclaus

    andrewclaus Active Member

    Joined:
    Sep 15, 2009
    993
    318
    0
    Location:
    Golden, CO
    Vehicle:
    2007 Prius
    At first glance probably not. I think the terminals are reversed, for one thing, and the vent hole is not visible.
     
  11. nbojaxhiu

    nbojaxhiu New Member

    Joined:
    Nov 25, 2016
    24
    2
    0
    Location:
    kosovo
    Vehicle:
    2004 Prius
    Model:
    Persona
    Finally decided to change the 12V battery and got it with a good price. Varta B33, 45 AH compatible for Prius. the paid proce is 49.50 Euro. Can anyone advise if l should consider something when replacing it? Thnx

    Posted via the PriusChat mobile app.
     
  12. andrewclaus

    andrewclaus Active Member

    Joined:
    Sep 15, 2009
    993
    318
    0
    Location:
    Golden, CO
    Vehicle:
    2007 Prius
    If you don't have a repair manual, search online for instructions. You have to do some minor disassembly (cooling air duct and electrical modules) to replace the battery. Some fasteners may be hidden. There's also a vent tube for the battery itself. Electrically, it's very easy if the battery is compatible.
     
    nbojaxhiu likes this.
  13. nbojaxhiu

    nbojaxhiu New Member

    Joined:
    Nov 25, 2016
    24
    2
    0
    Location:
    kosovo
    Vehicle:
    2004 Prius
    Model:
    Persona
    today l have personally changed the 12V battery as the old one was showing 9.2 V when vehicle on acc mode. But still even the battery changed i get the message " the external system not connected" means l have innoperative MFD. I thought the battery was the reason.
    I have put a Varta B33 which also has a vent hole but the hole seems to be smaller so l will install a smaller adapter to adjust the tube. Any ide why l this mesage come up and sometimes on a longer trip everything works well.thnx

    Posted via the PriusChat mobile app.
     
  14. nbojaxhiu

    nbojaxhiu New Member

    Joined:
    Nov 25, 2016
    24
    2
    0
    Location:
    kosovo
    Vehicle:
    2004 Prius
    Model:
    Persona
    Hi there, recently l have reported about MFD not beeing operative. I have studied a lot from experiences of others and removed MFD and went to a technician who did a resoldering of connectors and finally everything works perfect.

    Posted via the PriusChat mobile app.
     
  15. shanoan Anderson

    shanoan Anderson New Member

    Joined:
    Jul 25, 2018
    2
    0
    0
    Location:
    new york
    Vehicle:
    2006 Prius
    Model:
    II
    what does it mean when external system is not connected? my prius is saying that now
     
  16. hchu1

    hchu1 Active Member

    Joined:
    Sep 28, 2006
    315
    126
    0
    Location:
    Houston, Tx.
    Vehicle:
    2014 Prius v wagon
    Model:
    Two
    See the post above yours.

    You might contact these folks also, as their specialty is the Prius. They carry parts from salvaged vehicles which will cost less if you have to get another MFD.

    Prius hybrids sales and service Scottsburg Indiana
     
Loading...