1. Attachments are working again! Check out this thread for more details and to report any other bugs.

Traction/12v battery & Touchscreen Issue realted?

Discussion in 'Gen 3 Prius Main Forum' started by J0hnny, Aug 2, 2023.

  1. J0hnny

    J0hnny Junior Member

    Joined:
    Oct 23, 2021
    10
    4
    0
    Location:
    Bay Area
    Vehicle:
    2012 Prius
    Model:
    Three
    So my catalytic converter was stolen and my car sat for 10 months. They cut my coolant lines so I didn't even start the car once during the 10 month wait. Well the part finally came in and I got a new converter but to my surprise my touchscreen is not working now and I never had any signs of failure before. Even now there is no fading or glitching happening on the screen. Everything looks to work fine but cant get touch to work.

    During the 10 month wait I had the 12volt battery out of the car on a trickle charger but somehow when the catalytic converter was replaced the radio remembered all the settings like bluetooth and so on.

    Should I disconnect the traction and 12v battery for 10 minutes or so? Will that reset things? Will that get my touchscreen to work again?

    Trying to figure out if this was just a coincidence that the touchscreen went bad or if it was related to the car having to sit there for 10 months..

    2012 Prius three
    Stereo : 57032
     
    Tombukt2 likes this.
  2. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    8,395
    1,464
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    Yes I would certainly disconnect everything and make sure everything is dead has no milliamps no volts nothing for 5 minutes or something reconnect and see what you got as like most computers are reboot might be good.
     
  3. J0hnny

    J0hnny Junior Member

    Joined:
    Oct 23, 2021
    10
    4
    0
    Location:
    Bay Area
    Vehicle:
    2012 Prius
    Model:
    Three
    Sry for the late reply.. appreciate your input. Im really disappointed. There was nothing wrong with my radio and when I got my car back the touchscreen has failed. Ive tried everything including unplugging the traction and 12v batteries. Toyota service manager said "we see this all the time, just unplug the 12v and wait 10 min."

    Well, I tried that and no luck on recovering usage of my touch screen. Ive never experienced a glitch or fading or anything else regarding the screen previous to this incident so I feel like something is a miss here but I don't have enough experience with these cars to pin point something in particular in terms of causation.