1. Attachments are working again! Check out this thread for more details and to report any other bugs.

Trip and Display buttons dead - halographic heads up controls

Discussion in 'Gen 3 Prius Main Forum' started by Freefall_Doug, Jan 26, 2017.

  1. Freefall_Doug

    Freefall_Doug Junior Member

    Joined:
    Jun 17, 2014
    30
    3
    0
    Vehicle:
    2010 Prius
    Model:
    III
    Hi all, I am hoping I can get some trouble shooting help.

    My right side steering wheel trip and Display controls went dead. This car has the hologram display that would give you and indication of the button you partially pressed on the center display.

    The temp control on that same steering wheel switch is working.

    What is the best way to go about trouble shooting?

    A search here indicates a cable that goes bad, but also shows that there is a separate CPU for the holographic switches.

    I'm leaning towards electrical. When it first broke I got it to work one more time by banging on the steering wheel, but that was a one time caveman fix.

    I can't reset the trip, or oil change announcement until this gets fixed.

    Thanks!
     
  2. Mendel Leisk

    Mendel Leisk Senior Member

    Joined:
    Oct 17, 2010
    55,539
    38,709
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    If banging the steering wheel fixed it, maybe replacing that component will do the trick? Or God willing: it's just a loose or corroded connection in that switch?

    With all this hightech cr#p we really get dropped in it when things go, eh? :mad:
     
  3. Freefall_Doug

    Freefall_Doug Junior Member

    Joined:
    Jun 17, 2014
    30
    3
    0
    Vehicle:
    2010 Prius
    Model:
    III
    Bumping this, or maybe this would get more traction in a sub forum?

    Thanks!
     
  4. BZzap!

    BZzap! Senior Member

    Joined:
    Jun 13, 2012
    1,607
    877
    0
    Vehicle:
    2012 Prius
    Model:
    Two
    It's just a guess but the clock spring wire ribbon in the steering wheel hub may be the culprit. I'm surprised it didn't set off a warning light of some kind. That could be a good thing... I guess.
     
    Danno5060 likes this.
  5. Freefall_Doug

    Freefall_Doug Junior Member

    Joined:
    Jun 17, 2014
    30
    3
    0
    Vehicle:
    2010 Prius
    Model:
    III
    That was my original thought based on research on here. It sounds like it fails in different spots, and can get progressively worse. Right now the airbag light and other things haven't triggered/failed, but I suppose that could just be a matter of time.
     
  6. Brittany Maclaughlin

    Brittany Maclaughlin Junior Member

    Joined:
    Oct 18, 2021
    3
    0
    0
    Location:
    Phoenix
    Vehicle:
    2011 Prius
    Model:
    IV
    @freefallDoug did you ever get this fixed? I have a 2011 Prius with same problem!
     
  7. Max Pivnenko

    Max Pivnenko Junior Member

    Joined:
    Feb 22, 2022
    3
    0
    0
    Location:
    Minneapolis USA
    Vehicle:
    2010 Prius
    Model:
    Three
    Hello I see the post is very old, but... Today I have got the same problem. Did you solve it? Thanks
     
  8. alexk345

    alexk345 Junior Member

    Joined:
    Oct 22, 2022
    40
    3
    0
    Location:
    india
    Vehicle:
    2010 Prius
    Model:
    LE
    After jump buttons in steering wheel stopped working
     
  9. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    23,956
    15,569
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    There seem to have been several posts from different people in this thread over time.

    Per the thread title and the original post, this thread is about cars that have the Touch Tracer display (where you see a glowing outline of the steering wheel buttons over the speedometer when you touch them). In that version of the car, yes, there is a micro computer built into the steering pad switch, that sends messages over the single green "STRG" wire to the combination meter, telling it which buttons are being touched or pressed. These cars have the wiring shown with (*6) here ("w/ Touch Sensor"), and not the wiring shown with (*7).

    [​IMG]

    When posting on this thread about another car with a similar problem, it might be helpful to include as much information as possible from the following:

    • Do any of the steering wheel buttons work? Which ones?
    • Does the Touch Tracer display respond when any of the buttons are lightly pressed? Which ones?
    • Does the cruise control work? How about the passenger airbag on/off light, when there is weight in the passenger seat? (I mention those just as two easy things to check that happen to involve the same fuse that powers the steering pad micro computer.)
     
  10. gigi123

    gigi123 Junior Member

    Joined:
    Mar 20, 2021
    3
    0
    0
    Location:
    Texas
    Vehicle:
    2013 Prius v wagon
    Model:
    V
    I just wanted to post that a clockspring replacement fixed my problem (disp, trip and tracer were not working). Also, in my case the Cruise was inop and now it works. I didn't have any lights ON for airbag and also the horn was working. In fact everything was working but the disp trip and tracer (steering controls) and Cruise Control stalk.
     
  11. AzusaPrius

    AzusaPrius Senior Member

    Joined:
    May 27, 2020
    1,875
    821
    0
    Location:
    California
    Vehicle:
    2010 Prius
    Model:
    IV
    You can buy a cheap one on Ebay.

    That is what I did for $10 with zero problems.

    My trip button was not working and I was not able to see anything related to battery info because the oil maintenance message was there.

    No need to spend lots of money on a
    new/used OEM clockspring.
     
  12. KamiKKazi

    KamiKKazi Member

    Joined:
    Jul 19, 2021
    89
    58
    0
    Location:
    OC
    Vehicle:
    2010 Prius
    Model:
    Four
    There may be issues with the horn or cruise control if you do not use a oem part for the clock spring. Having these issues on a car I am working on after someone recommended the cheap clock spring.
     
  13. alexk345

    alexk345 Junior Member

    Joined:
    Oct 22, 2022
    40
    3
    0
    Location:
    india
    Vehicle:
    2010 Prius
    Model:
    LE
    ANy easy solution without going to mechanic? Mine happened during jump or oil change. Not sure who did this