Trying to Diagnose Check Hybrid System Failure Gen 3 Prius

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by jowapah, Dec 18, 2017.

  1. jowapah

    jowapah Junior Member

    Joined:
    Sep 8, 2017
    24
    8
    0
    Location:
    New York State
    Vehicle:
    2011 Prius
    Model:
    Two
    my 2011 Prius recently failed to start after sitting overnight, no warning, initially failed to start the ICE, was able to drive on Electric only for about 100 yards, Check Hybrid System Posted on display, was able to turn around and drive it into driveway, but now it won't even start into ready. Seems that the Inverter is trying to start the ICE, but stops after a couple of seconds of whining. I recorded the sound, and I'm hoping someone can ID whether this is something in the inverter failing, or something else. Not sure I can post an mp4 on the site, failed to allow me to add it. Is it possible to upload mp4's to the site. The sound of the whine is important I think to diagnosing the issue.

    Thanks...
     
  2. Travis Decker

    Travis Decker Active Member

    Joined:
    Jul 15, 2015
    139
    109
    0
    Location:
    Portland OR
    Vehicle:
    2012 Prius
    Model:
    II
    You're going to either need to get it scanned by a Toyota mechanic, or buy a mini VCI off of Amazon so that you can read fault codes and diagnostic information
     
  3. Mendel Leisk

    Mendel Leisk Underfoot

    Joined:
    Oct 17, 2010
    47,423
    33,839
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    Yeah I would get it down to a dealership let them look at it. Diagnosis should amount to more than $100. You might still be under hybrid warranty, and there's warranty extension on the inverter IIRC.
     
  4. jowapah

    jowapah Junior Member

    Joined:
    Sep 8, 2017
    24
    8
    0
    Location:
    New York State
    Vehicle:
    2011 Prius
    Model:
    Two
    Thanks, I bought a MVCI off Amazon, cannot get it to install successfully. Seems that the ones on Amazon are either bootlegged, with unauthorized software, wants me to update the Techstream that comes with the MVCI . Do you know of any stream on here that walks you thru installing MVCI and Techstream successfully. I've not found anything that comes close to accurate.
    Thanks
     
  5. Mendel Leisk

    Mendel Leisk Underfoot

    Joined:
    Oct 17, 2010
    47,423
    33,839
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    How many miles on it?
     
  6. ericbecky

    ericbecky Hybrid Battery Hero

    Joined:
    Mar 12, 2004
    4,364
    3,190
    1
    Location:
    Madison, Wisconsin
    Vehicle:
    2005 Prius
    Model:
    Two
    Are you using a Windows XP machine?
    That will be the easiest install.
    All other installs require additional steps and knowledge/learning/research.
     
  7. TMR-JWAP

    TMR-JWAP Senior Member

    Joined:
    Aug 12, 2016
    4,859
    5,042
    0
    Location:
    Columbia, SC
    Vehicle:
    2007 Prius
    Model:
    Touring

    Turn off your wireless connection. If the techstream software detects that you are online with a wireless connection, it will not let you get past the update screen. Disconnect from wireless signal and no more problem.
     
  8. Mendel Leisk

    Mendel Leisk Underfoot

    Joined:
    Oct 17, 2010
    47,423
    33,839
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    Before Original Poster gets too far down the garden path of self diagnosis, would be good to verify it's not a warranty item.
     
  9. Travis Decker

    Travis Decker Active Member

    Joined:
    Jul 15, 2015
    139
    109
    0
    Location:
    Portland OR
    Vehicle:
    2012 Prius
    Model:
    II
    If you post VIN number I can do TIS inquiry and send you specifics about warranty coverage......
     
  10. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    97,611
    44,285
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    how's the 12v health?
     
    Mendel Leisk likes this.
  11. jowapah

    jowapah Junior Member

    Joined:
    Sep 8, 2017
    24
    8
    0
    Location:
    New York State
    Vehicle:
    2011 Prius
    Model:
    Two
    Sorry, had to go back to work in between. I appreciate the attention you are providing. 1. Car has 265000 on it, I got it at 173000, the previous owner had gotten either the software update, or replaced the inverter no charge, not sure which. I called my local Toyota dealer to see if in fact it is the inverter, whether it would be covered a second time if it failed.
    2. Using Windows 7 32 bit. I will try to turn off wireless tip you suggest.
    3. Will get VIN number and post shortly.
    4. I suspected issues with 12V battery, as mine seemed to drain on load test to below 11V, and then recover slowly back to above 12V. So, I purchased a new one installed now. The Hybrid battery cells check out ok in my opinion, although I've seen much info on whats good and whats bad. I cleaned all connections, checked individual cell strength, all around 7.35-7.42V per cell. Total unloaded, 207.03V, under startup load 202V .
     
    mjoo and Mendel Leisk like this.
  12. jowapah

    jowapah Junior Member

    Joined:
    Sep 8, 2017
    24
    8
    0
    Location:
    New York State
    Vehicle:
    2011 Prius
    Model:
    Two
    Here's my VIN JTDKN3DU8B0289978 2011 Toyota Prius
     
  13. Travis Decker

    Travis Decker Active Member

    Joined:
    Jul 15, 2015
    139
    109
    0
    Location:
    Portland OR
    Vehicle:
    2012 Prius
    Model:
    II
  14. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    97,611
    44,285
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
  15. jowapah

    jowapah Junior Member

    Joined:
    Sep 8, 2017
    24
    8
    0
    Location:
    New York State
    Vehicle:
    2011 Prius
    Model:
    Two
    Yes, can see it, repaired January 2016.... do not know if that means the software repair, or IPM replaced.....
     
  16. jowapah

    jowapah Junior Member

    Joined:
    Sep 8, 2017
    24
    8
    0
    Location:
    New York State
    Vehicle:
    2011 Prius
    Model:
    Two
    While not being able to get the MVCI to work, in the meantime, got a Kobra ELM327 and Android Torque App. Don't think it will do Hybrid Diags, it posted these:
    P0335 - Powertrain Crankshaft Position Sensor A Circuit (my generic OBDII was posting this, thinking it is not relevant.)

    P0121 - Powertrain Throttle/Pedal Position Sensor/Switch A Circuit Range/Performance Problem
    P0123 - Powertrain Throttle/Pedal Position Sensor/Switch A Circuit High Input
    P2135 - Powertrain Throttle/Pedal Position Sensor/Switch A/B Voltage Correlation

    Maybe I'm skeptical, but could the overnight failure of the Sensor cause the vehicle to not start, and post Check Hybrid System on Dash?

    Going to continue to attempt install of MVCI and Toyota Techstream, can anyone confirm that if I do get this working, that it does read Hybrid specific codes?
     
  17. Travis Decker

    Travis Decker Active Member

    Joined:
    Jul 15, 2015
    139
    109
    0
    Location:
    Portland OR
    Vehicle:
    2012 Prius
    Model:
    II
    If you have a freeze frame for the P0335, what is MAF and RPM? If MAF is anything besides 0 and RPM says 0 you need a crank sensor
     
    TMR-JWAP likes this.
  18. jowapah

    jowapah Junior Member

    Joined:
    Sep 8, 2017
    24
    8
    0
    Location:
    New York State
    Vehicle:
    2011 Prius
    Model:
    Two
    Well, I had to replace the ICE about 12000 miles ago, so, already swapped the one from my old engine to no avail. Don't think that both of them could be defective..? Reason for the ICE replace, had catastrophic coolant loss on highway, warped head, had tried to re-do head, still had coolant issues, finally decided to drop a new/used ICE with 119000 miles on it. Has been fine for 12000 miles until this new issue
     
  19. jowapah

    jowapah Junior Member

    Joined:
    Sep 8, 2017
    24
    8
    0
    Location:
    New York State
    Vehicle:
    2011 Prius
    Model:
    Two
    Got the MVCI to work with Toyota Techstream, Hybrid System Code pulled is P0A0F - Engine Failed to Start . Many things to check such as MAF, Intake Manifold, Spark Plugs/coils. Any other ideas on what to look into?
     
  20. Travis Decker

    Travis Decker Active Member

    Joined:
    Jul 15, 2015
    139
    109
    0
    Location:
    Portland OR
    Vehicle:
    2012 Prius
    Model:
    II
    Do a PDF print of the freeze frame so that code and post it here
     
Loading...