Trying to install TechStream V13.00.022 on Win XP

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by iskoos, Jan 26, 2020.

  1. iskoos

    iskoos Active Member

    Joined:
    Dec 24, 2017
    302
    198
    0
    Location:
    Orlando, FL
    Vehicle:
    2010 Prius
    Model:
    III
    I bought the interface and the CD from ebay.

    The CD has the V13.00.022 files and the install video. But the video is Chinese and confusing.
    I have checked many other videos of V13 install but almost all on Win7 and the videos slightly differ from each other.

    I have an old Win XP laptop that I would like to use but cannot find install instructions of V13.00.022.

    Can anyone provide a link to any video or instructions?

    Or you could simply tell me what I need to do.

    So far I installed the software and replaced the MainMenu.exe and Techstream.exe files and stopped there.
    I don't how to move on with drivers installation.
     
    ydpplqbd likes this.
  2. Siward

    Siward Member

    Joined:
    Aug 7, 2014
    226
    96
    2
    Location:
    Toronto
    Vehicle:
    2012 Prius
    Model:
    Three
  3. iskoos

    iskoos Active Member

    Joined:
    Dec 24, 2017
    302
    198
    0
    Location:
    Orlando, FL
    Vehicle:
    2010 Prius
    Model:
    III
    Thank you for your reply.
    I already saw the link you referring to. First off, those for Win7. Mine is XP. I assume there has to be some minor changes. Most instructions are for Win7 unfortunately. I only found one for XP and it was for V10. Couldn't find any instructions of V13 on Win XP so far.

    The instructions you linked also differs from the other online instructions. I do not have the "Toyota new genkey" folder for example. I cannot copy/paste the TIS loader.
    The instructions I have (the Chinese ones) says I must copy/paste the "MainMenu.exe and TechStream.exe" files into the folder under the TechStream>Properties>Open file location.

    Then the instructions to install the "Device driver" is a bit different. These are the challenges I am facing.

    Guess I will go a head try and see if I get lucky. If not, then I will uninstall and then retry it.
     
  4. iskoos

    iskoos Active Member

    Joined:
    Dec 24, 2017
    302
    198
    0
    Location:
    Orlando, FL
    Vehicle:
    2010 Prius
    Model:
    III
    See the below for example. This is also V13.00.022 installation on Win7. But it is quite different than what the link you posted explains it.

    This video didn't even show the device driver installations.
    So there are different kind of installation.

     
    #4 iskoos, Jan 27, 2020
    Last edited: Jan 27, 2020
    ydpplqbd likes this.
  5. Grit

    Grit Senior Member

    Joined:
    Aug 22, 2017
    4,399
    3,332
    1
    Location:
    Wilkes Land
    Vehicle:
    2012 Prius
    Model:
    Four
    This is like trying to install Microsoft office 2019 on windows XP.
     
    Pro-289 likes this.
  6. iskoos

    iskoos Active Member

    Joined:
    Dec 24, 2017
    302
    198
    0
    Location:
    Orlando, FL
    Vehicle:
    2010 Prius
    Model:
    III
    Well, I think I got it. Here are the steps I took on Windows XP (Service Pack 3):

    1. Installed the Techstream via TechStreamsetup.exe
    2. Replaced the MainMenu.exe and TechStream.exe files in the bin file.
    3. Opened the TechStream software and selected the Area, Language and filled in the info lines (Name, phone #, address etc.)
    4. Then installed the Device drive "Mini VCI Driver for Toyota.msi"
    5. Ran the "MVCI Firmware Update tool" At this point, I connected the Mini VCI OBD2 interface to my laptop's USB port. My laptop found and recognized the USB device. I clicked on the "Device Info" and was able to see the Interface firmware info.
    6. Started the TechStream.exe the second time and clicked on "Connect to Vehicle" on the top left. I got prompted with the activation code. I entered the activation code and my 5000 days of subscription:) started at the bottom left.

    I haven't connected to my Prius yet. Hopefully that will go smooth... Can't complain for the money I spent regardless of the outcome.
     
    ydpplqbd and SFO like this.
  7. Siward

    Siward Member

    Joined:
    Aug 7, 2014
    226
    96
    2
    Location:
    Toronto
    Vehicle:
    2012 Prius
    Model:
    Three
    Well, I paid $9 USD for my mini vci from Aliexpress. It is a sunk cost if it doesn't work.

    I decided to buy mine off of AliExpress rather than Amazon when I learned that many sellers on Amazon are just resellers.
     
  8. RichG

    RichG Junior Member

    Joined:
    Nov 6, 2019
    15
    34
    0
    Location:
    Houston
    Vehicle:
    2012 Prius
    Model:
    V
    Hello -
    Is it working? Can you post where on ebay you purchased it? I'm thinking of getting one but not sure where to get it reliably.
    Thanks,
    Rich
     
  9. Nor'easter

    Nor'easter Junior Member

    Joined:
    Nov 16, 2019
    87
    61
    0
    Location:
    New Hampshire
    Vehicle:
    2010 Prius
    Model:
    II
    I bought this a few days ago. Painless install, no trojans, no viri, good experience. Firmware version is 1.4.1 (I expected 2.0). It works, so I guess I don't care (should I?).

    My install was on Win7 64 bit.
     
  10. ydpplqbd

    ydpplqbd Active Member

    Joined:
    Aug 1, 2019
    363
    168
    0
    Location:
    NJ
    Vehicle:
    2006 Prius
    Model:
    Three
    Trying to get my Techstream 13.00.022 setup properly on my windows XP laptop . I am little confused about replacing the MainMenu.exe and TechStream.exe files in the bin file.

    Where are you obtaining the files that they you are using to replace the existing MainMenu.exe and TechStream.exe files?


    Any assistance would be greatly appreciated.
     
  11. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    10,753
    14,713
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    Typically they are on the CD that accompanies the J2534 protocol harness;).

    When I got our Mini VCI cable several years ago, it came with a CD and on there was a video of what to do:).

    Good luck with your install and keep us posted(y).
     
    SFO and ydpplqbd like this.
  12. Peter123

    Peter123 Active Member

    Joined:
    Oct 30, 2018
    113
    112
    1
    Location:
    Los Angeles, CA
    Vehicle:
    2011 Prius
    Model:
    Two
    I cannot find it right now, but there was a good explanation of how to do this on a Toyota Tacoma forum,
     
  13. ydpplqbd

    ydpplqbd Active Member

    Joined:
    Aug 1, 2019
    363
    168
    0
    Location:
    NJ
    Vehicle:
    2006 Prius
    Model:
    Three
    I got the Techstream 13.00.022 program installed on my Dell Inspiron E1405 laptop with Windows XP. But it appears that the USB ports are not working properly. Because after I click on "Connect to Vehicle", I never receive the message "Initializing USB Communication." See pic snipped from the video that came with the software (please note, I purchased 13.00.022 software but received a video about v10.30.029). I have tried connecting with vehicle off, ready mode and two start hits without key on brake (whatever that is called). Still no communication.

    My thought is that the USB ports are not working thus no communication. Anyone know how to test USB ports on a Windows XP laptop for function?

    screenshot of USB_initialization.JPG
     
  14. SB6

    SB6 Member

    Joined:
    Jan 27, 2019
    210
    58
    0
    Location:
    Texas
    Vehicle:
    2010 Prius
    Model:
    II
    Sounds like you didn't install the driver for the cable

    Insert a different USB item and see if it works
     
    pjksr02, Tim Jones and ydpplqbd like this.
  15. ydpplqbd

    ydpplqbd Active Member

    Joined:
    Aug 1, 2019
    363
    168
    0
    Location:
    NJ
    Vehicle:
    2006 Prius
    Model:
    Three
    I tried a flash drive yesterday. Which was not recognized. After some research, I learned that the flash-drive was not recognized due to the USB protocols in place at the time Window XP was produced.

    Do you know what USB items will absolutely work with a WIndows XP USB port?
     
  16. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    10,753
    14,713
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    It could also be a COM port issue;).

    Another item to investigate(y).
     
    pjksr02 and ydpplqbd like this.
  17. ydpplqbd

    ydpplqbd Active Member

    Joined:
    Aug 1, 2019
    363
    168
    0
    Location:
    NJ
    Vehicle:
    2006 Prius
    Model:
    Three
    07172020_screenshot_directory_techstream_13.00.022.JPG I am posting a pic of the Techstream CD directory. See pic below. I watched the video and did as instructed. However, the following file was not used on the CD: mvci-x64.reg.

    I assumed the 64 in the name meant that this file was to be used by 64 bit systems (Windows Xp is 32 bit).

    Does anyone know what the mvci-x64.reg file is used for?
     
    #17 ydpplqbd, Jul 17, 2020
    Last edited: Jul 17, 2020
  18. ydpplqbd

    ydpplqbd Active Member

    Joined:
    Aug 1, 2019
    363
    168
    0
    Location:
    NJ
    Vehicle:
    2006 Prius
    Model:
    Three
    Thanks!!! I will investigate com port issues.
     
    Raytheeagle likes this.
  19. SB6

    SB6 Member

    Joined:
    Jan 27, 2019
    210
    58
    0
    Location:
    Texas
    Vehicle:
    2010 Prius
    Model:
    II
    Might be a USB driver issue. You said your laptop is a Dell? On Dell's website, find the driver download page for your laptop model. Once there, find the USB driver. Download and install that
     
    SFO, Raytheeagle and ydpplqbd like this.
  20. ydpplqbd

    ydpplqbd Active Member

    Joined:
    Aug 1, 2019
    363
    168
    0
    Location:
    NJ
    Vehicle:
    2006 Prius
    Model:
    Three
    Many thanks!!!! I will try this course of action later this afternoon (when I get a break from work).
     
    Raytheeagle likes this.
Loading...