What are all the rear inputs in my 2010 Prius e7022 head unit?

Discussion in 'Gen 3 Prius Audio and Electronics' started by loomis2, Feb 25, 2017.

  1. loomis2

    loomis2 Junior Member

    Joined:
    Jan 14, 2017
    35
    23
    0
    Location:
    Cincinnati, OH
    Vehicle:
    2010 Prius
    Model:
    V
    I am looking to replace my head unit in my 2010 Prius model e7022. It is the JBL with nav system. There are a lot of plugs that go into the back and I just wonder what they all are for. I'm sure one is xm radio, one is probably the microphone, etc. I have been searching all day trying to find a schematic or something to sort it all out but I haven't had any luck. Anyone help me out?

    Here is a photo of all the plugs themselves. I mostly wonder about this for when I have to hook up a harness for the new radio. How many of these plugs just won't end up being used?
     

    Attached Files:

  2. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    10,268
    7,547
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV


    The wiring diagram shows the pinouts for all those. I was asking the same questions last summer, so this labeled picture might help:

    [​IMG]

    The microphone and backup camera both account for some of the pins in L37. L38 and L39 both go to the separate XM tuner that's located under your seat. The USB interface box is also down there, which you surely don't care about, as any replacement unit you put in is sure to have its own USB.

    The gray square coaxial plug is your GPS antenna. The XM antenna connection (which you might need for your new unit) you can see in the opening behind the radio. It's plugged into an extension that goes to the XM tuner under your seat, but you can unplug it back there and plug it into your new receiver if you need it.

    The wiring diagram, like all the rest of your service info, is on techinfo.toyota.com.

    By the way, I later figured out the "??" blue connector is L105, a GVIF video input for use by the auto-park computer if you have it. It's not shown on the wiring diagram for the radio, but it is shown with the auto-park computer.

    -Chap
     
  3. loomis2

    loomis2 Junior Member

    Joined:
    Jan 14, 2017
    35
    23
    0
    Location:
    Cincinnati, OH
    Vehicle:
    2010 Prius
    Model:
    V
    Wow, that was fast, and exactly what I was looking for. Where did you find this? I swear I was looking for hours!
     
  4. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    10,268
    7,547
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    I guess it was kind of buried in my last post, but ... the wiring diagram, like all the rest of your service info, is on techinfo.toyota.com.

    -Chap
     
  5. loomis2

    loomis2 Junior Member

    Joined:
    Jan 14, 2017
    35
    23
    0
    Location:
    Cincinnati, OH
    Vehicle:
    2010 Prius
    Model:
    V
    I was able to piece that together after I responded. The thing that really helped was your photo labelling all the ports. I looked over the wiring diagrams again and it all made a bit more sense. (I am kind of new to this so the visual helped a lot.)

    Have you heard of anyone being able to use the factory mic with an aftermarket head unit? I intend to use the factory back-up camera since it is already installed in my car using a voltage step-down. Every post I have read on Prius Chat regarding aftermarket units seemed to insinuate that the factory mic won't work.

    The wiring harness that came with my Chinese radio didn't plug in to anything in my car so I ordered the PAC RP4.2-TY11 thinking that will at least give me the correct plugs to connect everything together. That should be here in a few days. I am getting a crash course in wiring to get this thing to work. Your help has been appreciated, believe me!
     
  6. loomis2

    loomis2 Junior Member

    Joined:
    Jan 14, 2017
    35
    23
    0
    Location:
    Cincinnati, OH
    Vehicle:
    2010 Prius
    Model:
    V
    So am I right that the L42 connector has the reverse wire (pink) and the parking brake wire (red)? I tried to connect the oem camera yesterday and I tapped in to both those wires. I also connected a 12 volt to 6 volt step down module and connected that to the power and ground wires that the radio is connected to and my whole dash started flickering and the car went dead. It had to be jumped and everything is fine now but I am wary about trying it again. I thought I screwed things up way worse.
     
  7. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    10,268
    7,547
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    I think you're right about the reverse and parking. You didn't mention which power and ground you tapped, so I can't opine on what happened there. Are you sure about the integrity of all your connections?

    -Chap
     
  8. cproaudio

    cproaudio Speedlock Overrider

    Joined:
    Jul 7, 2010
    2,397
    737
    0
    Location:
    CA
    Vehicle:
    2010 Prius
    Model:
    V
    Does your Pirus V have self parking? If do, the rear camera does not connect to the radio. It connects to the self parking ECU behind the glove box. When you shift into reverse, the head unit receives the reverse signal (+12V pink wire L42 plug) and converts it into canbus then goes to the self parking ECU and triggers the reverse camera. Camera power is also from the self parking ECU not the head unit. The reverse image (analog NTSC signal) goes from the rear camera to the self parking ECU. The ECU converts the analog NTSC signal into digital signal and routes to the head unit with self parking overlay through the GVIF cable (L105 plug).
     
  9. loomis2

    loomis2 Junior Member

    Joined:
    Jan 14, 2017
    35
    23
    0
    Location:
    Cincinnati, OH
    Vehicle:
    2010 Prius
    Model:
    V
    I bought the car used but I am pretty sure I don't have self-parking, just the rear camera. If I find out I have had self parking all these years I will feel pretty stupid, though. :) The wiring schematic shows a five pin plug with pink on one end and red on the other and that is what I have back there, too, so I am pretty confident I have the right wires, I just don't know why it didn't work.
     
  10. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    10,268
    7,547
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    Was there anything plugged into L105? That'd be the giveaway.

    -Chap
     
  11. loomis2

    loomis2 Junior Member

    Joined:
    Jan 14, 2017
    35
    23
    0
    Location:
    Cincinnati, OH
    Vehicle:
    2010 Prius
    Model:
    V
    Nope.

    I haven't really messed with vehicle wiring before this so I am not totally sure about my connections. I had to combine two harnesses together since the one that came with the radio had the wrong plugs on it for my car. I wired the red and black from the two harnesses together and the radio worked fine. When I added the harness for the rear camera I had to attach the 12-to-6 volt converter and I added the red and black wires from the converter to the other ones, so now I had three red connected together and three black connected together. That did not work so well. But I don't know where else I would connect the camera power and ground behind the radio. Here is a photo showing the wiring mess I made without the extra camera wiring for the L37 connector. Somehow I stuffed all that behind the radio and it works.
    [​IMG]
     
  12. cproaudio

    cproaudio Speedlock Overrider

    Joined:
    Jul 7, 2010
    2,397
    737
    0
    Location:
    CA
    Vehicle:
    2010 Prius
    Model:
    V
    If you have dynamic cruise control and lane keep assist, you have self parking. There are 2 buttons on lower right silver column on steering wheel that says "LKA" and a car icon. Another way to tell if you have self parking is there's a sonar clearance sensor on each side of the front bumper.
    [​IMG]
     
  13. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    10,268
    7,547
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    Another way to tell would be ... whether there was originally something plugged into L105.
     
  14. loomis2

    loomis2 Junior Member

    Joined:
    Jan 14, 2017
    35
    23
    0
    Location:
    Cincinnati, OH
    Vehicle:
    2010 Prius
    Model:
    V
    No on all counts. :)
     
  15. la_creme

    la_creme New Member

    Joined:
    Oct 14, 2018
    1
    0
    0
    Location:
    Merced, CA
    Vehicle:
    2010 Prius
    Model:
    III
    Dear fellow Prius Drivers and OP, two years later I am also going through a very similar situation since I have a 2010 Prius iii with JBL E7022 system. I bought a Seicane aftermarket stereo from abroad, loved the large screen display. Problem is, the harness does not match because it fits the system without the JBL amplifier. I figure I'll have to buy the Pac RP4.2-TY11, then cut and crimp/soslder wires like you did. But what I wonder is if you were able to retain the functionality of your factory backup camera after all your ordeal?. My back up plan for this is to install an aftermarket backup camera that uses the yellow video cable jack provided the Seicane stereo supports it. But I really want to avoid all that and retain the OEM backup camera.[​IMG] 9inchbackof.jpg s-l500 (1).jpg
     
  16. cproaudio

    cproaudio Speedlock Overrider

    Joined:
    Jul 7, 2010
    2,397
    737
    0
    Location:
    CA
    Vehicle:
    2010 Prius
    Model:
    V
    Have you gotten this installed? I just bought a similar head unit but not a Seicane. I'll be giving self parking which I hate but haven't used it in months. I can park way faster and better than the IPA. I'm hoping the IPA ECU can supply the camera power even when the radio is disconnected.
     
  17. Evoking

    Evoking Junior Member

    Joined:
    Aug 6, 2020
    60
    7
    0
    Location:
    Pomona
    Vehicle:
    2010 Prius
    Model:
    Base
    I eBay they have a kit that’s all a plug and play this guy that I’m buying the radio from said it’s all plug and play
     
Loading...