2013 Prius brake booster fail

Discussion in 'Gen 3 Prius Main Forum' started by IDs mak, Oct 19, 2021.

  1. IDs mak

    IDs mak Junior Member

    Joined:
    Feb 4, 2018
    28
    3
    0
    Location:
    Ny
    Vehicle:
    2006 Prius
    Model:
    ----USA----
    Hi forum.
    I have been driving my car with traction control light on and no issues. But today when I parked it and 30 minutes later it seems the brakes abs or booster just failed.
    I am getting a lot of codes.
    Pls see the attached pic

    Looks like abs system failed not sure where to start. IMG-20211019-WA0006.jpg
     
    #1 IDs mak, Oct 19, 2021
    Last edited: Oct 20, 2021
  2. IDs mak

    IDs mak Junior Member

    Joined:
    Feb 4, 2018
    28
    3
    0
    Location:
    Ny
    Vehicle:
    2006 Prius
    Model:
    ----USA----
    When I start the car the abs, traction and brake lights are On and the car has a beep nonstop
    Brakes are 5% and paddle feels like dead
     
  3. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    14,669
    10,293
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    Those screenshots look like car that has been piling up one unfixed issue on top of another for years....
     
  4. IDs mak

    IDs mak Junior Member

    Joined:
    Feb 4, 2018
    28
    3
    0
    Location:
    Ny
    Vehicle:
    2006 Prius
    Model:
    ----USA----
    There had no light besides the traction control and the Car passed the inspection 3 weeks ago.
    May be there were issues but nothing to show for it.
     
  5. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    14,669
    10,293
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    There is a C1241 in there, indicating a low power supply voltage arriving at the brake ECU.

    That doesn't always mean the 12 volt battery, because the code is about the voltage arriving at the ECU up front, so wiring or connector problems are also possible.

    Nonetheless, if you have not measured the voltage of the 12 volt battery, it would be a natural place to start, especially when that code is present.
     
  6. Mendel Leisk

    Mendel Leisk Sand Pounder

    Joined:
    Oct 17, 2010
    45,563
    32,533
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    Just to confirm: this IS a 3rd gen (you're posted in a 3rd gen forum), or 2nd gen (per your avatar)?
     
  7. IDs mak

    IDs mak Junior Member

    Joined:
    Feb 4, 2018
    28
    3
    0
    Location:
    Ny
    Vehicle:
    2006 Prius
    Model:
    ----USA----
    My car is gen3 2013. I think this is my 10th Prius . IIRC
     
    Mendel Leisk likes this.
  8. IDs mak

    IDs mak Junior Member

    Joined:
    Feb 4, 2018
    28
    3
    0
    Location:
    Ny
    Vehicle:
    2006 Prius
    Model:
    ----USA----
    Tried to reset the light using a mecha I shop computer (borrowed from a friend ) and after that the car brakes are working normally. I still sense the paddle is not as responsive. So the booster or brake pump is not working. Bit I can drive the car. The brake and abs lights are on with traction control .
    Least the car is moving and I can take it to a shop.
     
    Mendel Leisk likes this.
  9. amarino

    amarino Member

    Joined:
    Mar 13, 2018
    53
    49
    60
    Location:
    CA
    Vehicle:
    2015 Prius
    Model:
    Two
  10. IDs mak

    IDs mak Junior Member

    Joined:
    Feb 4, 2018
    28
    3
    0
    Location:
    Ny
    Vehicle:
    2006 Prius
    Model:
    ----USA----
    My 12 v battery measures 11.70v on battery terminals before starting the car and 14.2 vonce the car is On and motor is running or not.
     
  11. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    14,669
    10,293
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    In that case, the C1241 probably indicates an issue in the wiring or connectors bringing power to the brake ECU.
     
  12. IDs mak

    IDs mak Junior Member

    Joined:
    Feb 4, 2018
    28
    3
    0
    Location:
    Ny
    Vehicle:
    2006 Prius
    Model:
    ----USA----
    What is the brake ecu location
     
  13. IDs mak

    IDs mak Junior Member

    Joined:
    Feb 4, 2018
    28
    3
    0
    Location:
    Ny
    Vehicle:
    2006 Prius
    Model:
    ----USA----
    Did a recent scan as the car was driving just fine other than the brake, abs and traction light these are the active codes.
    C1203 ecm communication circuit
    C1231 steering angle sensor
    C1345 liner solenoid value offset learning undone

    See the attached l
     

    Attached Files:

  14. IDs mak

    IDs mak Junior Member

    Joined:
    Feb 4, 2018
    28
    3
    0
    Location:
    Ny
    Vehicle:
    2006 Prius
    Model:
    ----USA----
    It turns out the master cylinder and brakes booster was the culprit.
     
    Solar Blue likes this.
Loading...