1. Attachments are working again! Check out this thread for more details and to report any other bugs.

Did the dealership mess up my brakes?

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Jeff S., Jun 19, 2016.

Tags:
  1. Jeff S.

    Jeff S. Junior Member

    Joined:
    Jun 11, 2016
    17
    2
    0
    Location:
    Michigan
    Vehicle:
    2009 Prius
    Model:
    Two
    2009 Prius with 129K

    I had my brakes “flushed” by a Toyota dealership

    A few days after the flush I started to hear the noise caused by the brake actuator pump ALOT more often. Like every other time I use the brakes in some cases.

    Here are my questions:

    1) Is this because I was on a long road trip in hot summer heat?

    2) Is it possible the dealership messed up the break flush and damaged the solonoid valves?

    3) Is it normal to hear the brake actuator pump after basically every other time I depress the brakes?


    No lights are on, and it doesn’t feel like I have lost any pressure in the brakes.


    The car is at 128,000 miles so warranty is out of the question but I might take it back to the dealership and discuss the possibility his technician messed up the car. They told me they have only done a brake flush on a prius “3 or 4 times” and it took them 6 hours.


    They recommended I get the flush when they inspected the car for me before I bought it.
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    108,111
    49,140
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    perhaps they didn't get all the air out of the lines?
     
  3. PriusInParadise

    Joined:
    May 24, 2012
    180
    91
    0
    Location:
    Hawaii
    Vehicle:
    2011 Prius
    Model:
    Two