Engine rattle at low rpm acceleration

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by Channaaj, Jul 23, 2016.

  1. Channaaj

    Channaaj New Member

    Joined:
    Jul 23, 2016
    8
    1
    0
    Location:
    Sri Lanka
    Vehicle:
    2010 Prius
    Model:
    III
    I'm having a trouble when accelerating at low rpm the engine begins to rattle. Tried removing the connector plug on the egr, to my surprise the rattle is gone but the engine light comes on saying that the EGR circuit is incomplete. Took it to the dealer and they diagnosed it to be the EGR valve opening but failing to close, so they instead proposed to fill in gas with a bottle of their injector cleaner. That made no difference, so tried replacing the EGR valve but again makes no difference. What could the culprit be?
     
  2. tankyuong

    tankyuong Active Member

    Joined:
    Nov 9, 2012
    602
    139
    0
    Location:
    Central MO
    Vehicle:
    2010 Prius
    Model:
    III
     
    Channaaj likes this.
  3. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    2,284
    2,361
    0
    Location:
    Fairfield, CA
    Vehicle:
    2010 Prius
    Model:
    II
    How many miles on her? When you replaced the egr valve, was there a lot of carbon deposit present, particularly on the plunger or around where the plunger seats?
     
    Channaaj likes this.
  4. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    60,265
    20,676
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    what made you try removing the plug to the egr?
     
    Channaaj likes this.
  5. Channaaj

    Channaaj New Member

    Joined:
    Jul 23, 2016
    8
    1
    0
    Location:
    Sri Lanka
    Vehicle:
    2010 Prius
    Model:
    III
    I'll do that too and will give an update
     
  6. Channaaj

    Channaaj New Member

    Joined:
    Jul 23, 2016
    8
    1
    0
    Location:
    Sri Lanka
    Vehicle:
    2010 Prius
    Model:
    III
    still 68000 on the meter, As I remember there was a whole lot of gunk of carbon deposit on the valve
     
  7. Channaaj

    Channaaj New Member

    Joined:
    Jul 23, 2016
    8
    1
    0
    Location:
    Sri Lanka
    Vehicle:
    2010 Prius
    Model:
    III
    thats because I checked many other things that could cause the trouble, cleaned the injectors, cleaned the spark plugs, cleaned the manifold, cleaned the egr pipe. so still no luck and decided to remove the EGR connector to see the outcome.
     
    bisco likes this.
  8. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    2,284
    2,361
    0
    Location:
    Fairfield, CA
    Vehicle:
    2010 Prius
    Model:
    II
    68 k seems early for large carbon deposits. Have you experienced any oil consumption? Do you use Top Tier detergent fuel? Now that you have been able to determine the temporary fix, the challenge becomes addressing it. If you saw large carbon on the valve and cleaned the egr pipe, have you done the intake manifold? Egr cooler? Throttle body cleaning? Thrown any codes other than the ones you have when you disconnected the egr valve electronics?
     
    Channaaj likes this.
  9. Channaaj

    Channaaj New Member

    Joined:
    Jul 23, 2016
    8
    1
    0
    Location:
    Sri Lanka
    Vehicle:
    2010 Prius
    Model:
    III
    I'm currently using 95 octane fuel, haven't noticed a oil consumption, but noticed there was a bit of oil in the intake manifold while cleaning it. even cleaned the throttle body at the dealer's. No codes other than the one that comes when I removed the EGR connector. Now my suspect is to replace the EGR cooler and if it doesn't work try replacing the spark plugs.
     
  10. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    2,284
    2,361
    0
    Location:
    Fairfield, CA
    Vehicle:
    2010 Prius
    Model:
    II
    Oil below the throttle plate is normal. Also consider the intake manifold for cleaning. The passages there can get plugged as well.

    Did you just clean and inspect the spark plugs or did you already replace them? It would be a little early for replacement, but trying to establish what has been done to the car.
     
    Channaaj likes this.
  11. Channaaj

    Channaaj New Member

    Joined:
    Jul 23, 2016
    8
    1
    0
    Location:
    Sri Lanka
    Vehicle:
    2010 Prius
    Model:
    III
    I cleaned the intake manifold, replaced the spark plugs and the EGR valve and the cooler. But still no improvement.
     
  12. tankyuong

    tankyuong Active Member

    Joined:
    Nov 9, 2012
    602
    139
    0
    Location:
    Central MO
    Vehicle:
    2010 Prius
    Model:
    III
    check 12v battery then do a compression check on engine ,you might have blown head gasket.
     
    Channaaj likes this.
  13. leese

    leese Junior Member

    Joined:
    Oct 2, 2008
    2
    1
    0
    Vehicle:
    2007 Prius
    Did you find out what the problem was? I believe I am having the same issue. It doesn't vibrate at idle but a little above idle while at a steady cruising rpm. I have taken it into the dealer twice and they have changed the spark plugs and changed the EGR valve. It is also not giving a code for them to pull. I have an appointment next week when the factory tech is there and will post if they find anything.
     
  14. davidvedenskii

    davidvedenskii New Member

    Joined:
    Tuesday
    6
    3
    0
    Location:
    San Francisco
    Vehicle:
    2010 Prius
    Model:
    Two
    experiencing the same issue. Was trying to clean IM, EGR Pipe, EGR valve, replaced spark plugs - didn't help. 2010 Prius 169k
     
  15. Dxta

    Dxta Member

    Joined:
    Nov 7, 2016
    409
    84
    0
    Location:
    Lagos
    Vehicle:
    2010 Prius
    Model:
    III
    Could you guys experiencing this problem, post a short video of the noise pls? The noise might be similar to a job I have done on a Prius 08. Might be coming from the valve train area, or in the piston/crankshaft location.

    Does the rattle come up when you guys kinda accele lightly owhen driving?
     
  16. kc410

    kc410 Active Member

    Joined:
    Nov 26, 2013
    207
    150
    0
    Location:
    SE FL
    Vehicle:
    2010 Prius
    Model:
    IV
    I had a low RPM engine rattle that would appear when the traction battery was down to two bars & I was trying to accelerate from a stop. Sitting in the Prius, running the AC, the battery will get to 2 bars, then the ICE starts to recharge the traction battery. If I then decide to drive off, the engine will rattle when I am accelerating from a stop.
    This was repeatable at any time.
    Cleaning the fully plugged EGR Cooler was the solution to this problem. All of my EGR circuit (intake manifold, intake manifold pipe, EGR valve) had lots of carbon buildup. Only the EGR cooler was fully plugged.
    Its been exactly a month since I've cleaned the EGR circuit & the problem has never reappeared :)
     
    davidvedenskii, mjoo, RMB and 2 others like this.
  17. davidvedenskii

    davidvedenskii New Member

    Joined:
    Tuesday
    6
    3
    0
    Location:
    San Francisco
    Vehicle:
    2010 Prius
    Model:
    Two

    how would u rate in terms of complexity (x out of 10) to clean EGR cooler?
     
    Raytheeagle likes this.
  18. davidvedenskii

    davidvedenskii New Member

    Joined:
    Tuesday
    6
    3
    0
    Location:
    San Francisco
    Vehicle:
    2010 Prius
    Model:
    Two
    This is exactly what’s happening. Not necessarily having low battery level for that, just slight ICE acceleration below 20mph
     
  19. kc410

    kc410 Active Member

    Joined:
    Nov 26, 2013
    207
    150
    0
    Location:
    SE FL
    Vehicle:
    2010 Prius
    Model:
    IV
    Not difficult, a royal pita to get to...this thread is the documentation of my work:
    Finally replaced EGR valve/cooler today | Page 2 | PriusChat

    Another Prius Chat member, NutzAboutBolts, has created many fine maintenance videos located here:
    Nutz About Bolts Prius Maintenance Videos | PriusChat

    Specifically here you are going to need the 1) Spark plugs replacement video to remove the windshield wiper assembly, then you can use the 2) Cleaning intake manifold video to get the intake out of the way, then the last two are the 3) EGR pipe cleaning & the 4) EGR Cooler Removal/Cleaning video.

    It does help to have a spare clean EGR cooler to install as the cleaning can easily take a couple days or more.

    In the end it is all worth it.

    Maybe think about installing an Oil Catch Can at the same time.
     
    Raytheeagle likes this.
  20. Dxta

    Dxta Member

    Joined:
    Nov 7, 2016
    409
    84
    0
    Location:
    Lagos
    Vehicle:
    2010 Prius
    Model:
    III
    his same problem has being happening in a friends car recently. Maybe, would have all that intakes, and Engr, cleaned up, or replaced.

    Dxta
     
Loading...