Installed Android/Carplay HU on Prius 2010, but sound quality is awful!

Discussion in 'Gen 3 Prius Audio and Electronics' started by Dhanish Jabbar, Aug 14, 2021.

  1. Dhanish Jabbar

    Dhanish Jabbar New Member

    Joined:
    Aug 14, 2021
    1
    0
    0
    Location:
    Uk
    Vehicle:
    2010 Prius
    Model:
    N/A
    I recently installed a android px9 head unit from alibaba into my 2010 Prius T Spirit. The carplay functionality and ability to watch youtube when parked up is amazing.

    However the sound quality from the soeakers is noticeably less “punchier” than the stock toyota HU. Previously the old HU would literally rattle my rear view mirror from the bass. But this new head unit alothough it has DSP, I can seem to set the EQ right to get that same level of bass no matter what I do? Its like it is bypassing the sub.

    Am I doing something wrong? Does the headunit need a amp or something?
     

    Attached Files:

  2. sam spade 2

    sam spade 2 Senior Member

    Joined:
    Mar 31, 2018
    5,607
    2,233
    0
    Location:
    USA
    Vehicle:
    2017 Prius c
    Model:
    Four
    I suggest that you contact the maker of your new head unit.
     
    Dhanish Jabbar likes this.
  3. Ed Beaty

    Ed Beaty Active Member

    Joined:
    Jul 13, 2018
    331
    304
    0
    Location:
    Salt Lake City
    Vehicle:
    2010 Prius
    Model:
    IV
    From a post by PC members TroyAndEddie in 2015: Headunit upgrade with JBL | PriusChat
    Scroll UP to post #6 for a long post that may contain info pertinent to your issue. Read particularly: WHEN INSTALLING IN A JBL-EQUIPPED CAR: (read all the steps in that segment).
     
    Dhanish Jabbar likes this.
  4. prius2010II

    prius2010II Member

    Joined:
    Aug 19, 2010
    249
    19
    0
    Location:
    us
    Vehicle:
    2010 Prius
    Model:
    III
    You need a canbus adapter if your car.has JBL.amp. There are at least 2 different wiring harness.. Take a picure of the back of your factory radio or factory harness. Email to your dealer.

    There should be a menu setting to turn on factory amp.
     
  5. Evoking

    Evoking Junior Member

    Joined:
    Aug 6, 2020
    86
    16
    0
    Location:
    Pomona
    Vehicle:
    2010 Prius
    Model:
    Base
    I have an android head unit and the factory jbl system and I absolutely love the sound.
     
  6. JamiFids

    JamiFids New Member

    Joined:
    Sep 14, 2021
    7
    1
    0
    Location:
    USA
    Vehicle:
    2010 Prius
    Model:
    Four Touring
    If you installed the Android device separately from the stereo system, it is possible through the incompatibility of the devices. Try to buy the original.
     
Loading...