Wires connection of back-up camera to MFD !!!

Discussion in 'Gen 2 Prius Audio and Electronics' started by cozmisu, Oct 20, 2012.

  1. DangNabbit

    DangNabbit Junior Member

    Joined:
    May 13, 2018
    54
    11
    0
    Location:
    Where the wild things are
    Vehicle:
    2008 Prius
    Model:
    I
    Definitely will do! I was planning on taking the pictures for a more up to date how to posting if it worked.
     
  2. DangNabbit

    DangNabbit Junior Member

    Joined:
    May 13, 2018
    54
    11
    0
    Location:
    Where the wild things are
    Vehicle:
    2008 Prius
    Model:
    I
    Small update:
    I’ll need to find the reverse wire. Got into the secret menu and REV says “off” while in reverse.
     
  3. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    Here's what I had to do to put a 2006 High-res MFD in my 2004 basic Prius.
    (The pins on the diagram for "B" in 2006 matched the pins on my basic 2004 -- a 2008 may be different.)
    Prius M13 2006.png
     
    #103 ITBland, Jun 14, 2018
    Last edited: Jun 14, 2018
    DangNabbit likes this.
  4. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    Here is where the Reverse signal should be: (again, from a 2006, so 2008 may be different) this connector is vertical in the car, behind the air vent dash trim to the right of the radio in a US car. (*This is probably missing on a basic Prius AND a lot of wires to contend with, it may be simpler to just go to the J10 connector mentioned in the next post.)
    Prius_2006_CenterConnector2.png
     
    #104 ITBland, Jun 14, 2018
    Last edited: Jun 14, 2018
    DangNabbit likes this.
  5. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    If you don't have the Red wire at 5N, pin 14 in Connector 2, then the Red wire(s) at A in connector J10 in the passenger kick panel area (in a US Prius) is the switched 12v+ going to the backup lights. (And, where the Red wire to Connector 2 should have come from!) --Always check with a meter to verify voltage/signal!
    Prius_2006_J10_Connector.JPG
    2006PriusInstPanelLocations.JPG
    (2006 wiring diagram)
     
    #105 ITBland, Jun 14, 2018
    Last edited: Jun 14, 2018
    DangNabbit likes this.
  6. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    Here is the wiring diagram for the reverse signal to the 2006 MFD (Note that the J10 connector also sends the Backup voltage down to the backup lights on that Red wire. Do not power the camera from here! The camera must be "sensed" by the MFD during its "boot up", so it is best to use the power pins it provides, M14 pin 27 (V+) and pin 28 (V-) (I would also add an inline fuse to the camera V+ wire coming out of the M13 connector at the MFD, so I wouldn't harm the MFD if I shorted the wire by accident.))
    Rev2006PriusMFDZoom.JPG
    *3 w/Television Camera (High-res MFD)
    *4 w/out Television Camera (Low-res MFD) 2006 wiring diagram
     
    #106 ITBland, Jun 14, 2018
    Last edited: Jun 14, 2018
    DangNabbit likes this.
  7. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    This is a good picture of the connectors (connectors mislabeled in this picture, these are M14 and M13)
    [​IMG]
    from the earlier post #52 in this thread.
    (I got my missing M14 connector with the 2006 MFD from the junkyard.)
    If you are missing some of the wires and pin connectors, another thread mentioned that the old audio connector from a CD in an older computer is a good "donor". (Keep the video signal shielded as much as possible before splitting out to the connector wires.)
    prius_CDaudioConnector.JPG
     
    #107 ITBland, Jun 14, 2018
    Last edited: Jun 14, 2018
    DangNabbit likes this.
  8. DangNabbit

    DangNabbit Junior Member

    Joined:
    May 13, 2018
    54
    11
    0
    Location:
    Where the wild things are
    Vehicle:
    2008 Prius
    Model:
    I
    ItBland,
    Thank you! I’m going to print this out and study this.

    I didn’t realize it was going to be this involved. I’m too far in this project, I have to complete it now!

    I have a feeling I’ll post back asking some more questions.
     
  9. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    You should probably ignore post #104 above, and just go for the wire in connector J10 for the reverse signal, much easier to get to and much easier to work with fewer wires. Also the picture in #106 is only valuable if you like to look at schematics, it really doesn't add anything. However, some have found out the hard way that if you try to power the camera from the reverse lights. it won't work with the MFD, so adding that advice was the good part of that post. Also, if you don't have an M14 connector (and can't find one in a junkyard) the CD connector (shown in #107) can be used--it has the correct spacing for the four camera pins on the back of the MFD.
     
  10. DangNabbit

    DangNabbit Junior Member

    Joined:
    May 13, 2018
    54
    11
    0
    Location:
    Where the wild things are
    Vehicle:
    2008 Prius
    Model:
    I
    ItBland,
    Just to confirm, you’re saying the m14 connector (larger one) is missing from the base MFD? I haven’t taken the dash apart yet to look in my vehicle.
     
  11. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    On my basic 2004, I only had one connector, M13 (labeled incorrectly in the picture as M12). In the wiring diagram, M14 is where the camera and Bluetooth connections are. The 4 backup pins are in a row, so you can just use a 4-pin CD audio connector cable on them, if you don’t junkyard a M14 connector (it is a good, tight fit)
     
  12. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    upload_2018-6-27_11-3-4.gif
    (Typical computer CD audio cable)
     
  13. DangNabbit

    DangNabbit Junior Member

    Joined:
    May 13, 2018
    54
    11
    0
    Location:
    Where the wild things are
    Vehicle:
    2008 Prius
    Model:
    I
    Gotcha. I thought they all came with the m14 and we had to use the cd rom cable to attach somehow to the camera. I must have misunderstood.

    So the cd rom cable is used to plug in as a mini pseudo m14 connector?

    In this case I’ll have to crack open the dash and look behind to see if mine is prewired.

    I do have the camera connector wires on the top part of the hatch. I posted pictures on @V Paki thread.
     
  14. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    Yes
    Hopefully, since the wires are in the roof, they run all the way to the MFD. (That would make it easier for a dealer to add the camera option, but I don’t know if Toyota dealers offered that)
     
  15. DangNabbit

    DangNabbit Junior Member

    Joined:
    May 13, 2018
    54
    11
    0
    Location:
    Where the wild things are
    Vehicle:
    2008 Prius
    Model:
    I
    Here is the back end picture of the high res mfd.

    [​IMG]
     
  16. DangNabbit

    DangNabbit Junior Member

    Joined:
    May 13, 2018
    54
    11
    0
    Location:
    Where the wild things are
    Vehicle:
    2008 Prius
    Model:
    I
    Here are the back end pictures and wiring of the BASE NON HIGH RES MFD.

    Note: I have a 2008 Level 1 Base prius.
    I only have one connector going into the back of the MFD screen.

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
  17. DangNabbit

    DangNabbit Junior Member

    Joined:
    May 13, 2018
    54
    11
    0
    Location:
    Where the wild things are
    Vehicle:
    2008 Prius
    Model:
    I
    Status Update...
    • High res MFD installed. Wires re-done.... The small violet wire was a tough one. I had to yank it out and ruined the plastic in spot #25 on that connector. Originally I left the violet in #25 and I got the red triangle.... Moved it and all is well. MFD works great... Responsive touch screen and all the buttons work.
    • MFD diagnostics shows REV ON and OFF when switching to reverse.
    • Pink wire to #21 on MFD connector was already there.

    Problem:
    The camera does not show up on the MFD... I think I have to hookup the CD ROM connector.

    @ITBland where should I be looking for the 4 camera wires near the front passenger side... This is assuming the 4 pin wire connector for the camera (in the hatch) runs all the way to the front dash. I'm assuming I have to connect the 4 pin CD ROM cable from the M14 to somewhere in the passenger dash??
     
  18. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    Yes, the camera wires go to M14, that you do not have. Here are the pictures of the circuit:
    Prius_Body_wire_2006.JPG Prius_Camera_2006.JPG
    IQ1 must be where M13 connects to the main harness, but you can see BH1 - Look for the shielded cable, that will be the camera, (presuming there is no other shielded cable in there :(
    Aha, IQ1 says Floor to LH Front Console Box - looking for a diagram!
    Prius_2006_IQ1.png Prius_2006_IQ1_zoom.JPG
     
    #118 ITBland, Jun 29, 2018
    Last edited: Jun 29, 2018
  19. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    There must be a different harness inside the dash for the hi-res MFD, sorry! (Remember, I have a 2004, I KNEW I had to run mu own wires to the MFD. Red circles above are my best guess--It appears that the entire dash loom is different!
     
    #119 ITBland, Jun 29, 2018
    Last edited: Jun 29, 2018
  20. ITBland

    ITBland Active Member

    Joined:
    Jun 22, 2017
    433
    244
    3
    Location:
    New Orleans, La area, US
    Vehicle:
    2011 Prius
    Model:
    Three
    Looks like you will need 6-ish feet of shielded audio cable plus two wires for power. If you find IQ1 (looks like it’s under the driver’s seat) and measure how much length you need, I have a short piece of cable that might be long enough and you can wait for the mail. (It’s nothing special, just one shielded cable with either 3 or 4 wires.)
     
Loading...